Couldn't find a valid ICU package

technologiessunny's Avatar

technologiessunny

20 Dec, 2017 09:28 PM

I am trying to deploy a docker image to a deployment target (which is a bare metal centos7 image) but getting

FailFast: Couldn't find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.

Please help

  1. Support Staff 1 Posted by Daniel Fischer on 21 Dec, 2017 05:45 AM

    Daniel Fischer's Avatar

    Hi Technologiessunny,

    Thanks for getting in touch! Where is it that you are seeing this error? If it's during your deployment, would you be able to attach a full deployment log?

    If not, would you be able to provide some further information about your problem?

    Looking forward to hearing from you.

    Best regards,
    Daniel

  2. 2 Posted by sowen on 09 Apr, 2018 10:18 PM

    sowen's Avatar

    Also seeing this issue when trying to install octo.exe on ubuntu

    apt-get update -qq; apt-get install wget tar libunwind8 -y
    wget -qO- https://download.octopusdeploy.com/octopus-tools/4.31.7/OctopusTools.4.31.7.ubuntu.16.04-x64.tar.gz | tar xvz
    ./Octo
    

    FailFast: Couldn't find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.

  3. 3 Posted by sowen on 10 Apr, 2018 02:58 AM

    sowen's Avatar

    I worked around the issue by installing these packages

    libunwind8 icu-devtools
    

    Most likely my issue stemed from the fact that I'm running inside a docker container

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac