"CreateProcess error=206, The filename or extension is too long" when running Octo.exe

DJ Sitte's Avatar

DJ Sitte

05 Feb, 2018 03:41 PM

I'm currently trying to run the Octopus 'Create and Push Packages' build step in TeamCity and Octo.exe is giving me this error:

[Octopus Deploy] Error from Octo.exe: Cannot run program "C:\TeamCity\buildAgent\temp\buildTmp\octo-temp\3.0\octo.exe" (in directory "C:\TeamCity\buildAgent\work\f0b47ced5bc97d9e"): CreateProcess error=206, The filename or extension is too long
[09:23:35][Octopus Deploy] Error from Octo.exe: Cannot run program "C:\TeamCity\buildAgent\temp\buildTmp\octo-temp\3.0\octo.exe" (in directory "C:\TeamCity\buildAgent\work\f0b47ced5bc97d9e"): CreateProcess error=206, The filename or extension is too long
[09:23:35][Octopus Deploy] Step OctopusDeploy: Create and Push Packages failed with unexpected error

  1. 1 Posted by DJ Sitte on 05 Feb, 2018 03:42 PM

    DJ Sitte's Avatar

    I've already checked the paths of the files being packed and none of them come close to Windows MAX_PATH

  2. Support Staff 2 Posted by Shaun Marx on 06 Feb, 2018 05:34 AM

    Shaun Marx's Avatar

    Hi DJ, thanks for reaching out.

    That is very strange, it looks like the process is failing to start octo.exe which is not something we have seen before. I have tried to replicate this but to no avail. I think in order to help you, we may need a bit more information to try and figure out what is going on here.

    Is this a java or node application that you are trying to package by chance?

    If you could also attach a full build log from TeamCity that may help us pinpoint the problem as well.

    Hope to hear back from you soon.

    Regards,
    Shaun Marx

  3. 3 Posted by Dennis on 07 Jun, 2018 11:51 AM

    Dennis's Avatar

    I get this error too, did you solve it?

  4. 4 Posted by phu on 23 Aug, 2018 08:08 AM

    phu's Avatar

    I think this error occurs when octo.exe ends up getting called with a lot of --package parameters. Just started hitting this error when building in TeamCity. For the sake of testing, I tried to remove nearly all of the --package parameters which made the error go away... but the package is of course incomplete.

    Edit: Changing the package target extension to .zip instead of .nupkg fixed this.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac