How to set Enabled Protocols and Authentication mode for a IIS Web Application?

pnolan's Avatar

pnolan

14 Nov, 2017 10:19 PM

Hi,

The "Deploy to IIS" step doesn't seem to allow the "Enabled Protocols" or "Authentication" mode to be set when configured for a "IIS Web Application" deployment type.

Our "IIS Web Application" has slightly different settings to the parent IIS Web Site.

This a a fundamental requirement when creating most websites.

Am I missing something or is this currently not possible? Is it something that will be possible soon?

Thanks heaps!

  1. Support Staff 1 Posted by Reece Walsh on 15 Nov, 2017 06:04 AM

    Reece Walsh's Avatar

    Hi Pnolan,

    Thank you for contacting Octopus Deploy support in regards to this query,

    Unfortunately, at this stage, it's not possible by default to enable protocols or authentication credentials when specifying the "IIS Web Application" type.

    This has been raised in our User Voice area previously, feel free to leave a vote for this in addition to your thoughts. This is our main avenue when considering new features/enhancements like this based on community support.

    There are a few workarounds which I've added below that should be able to assist;

    1) There exists a Step Template which you can use, but since this template was created by the community we do not have any additional documentation at this stage.

    2) Alternatively, you can look at adding a custom PowerShell script to do this, I've found some online examples regarding this;

    PS Script to Enable Protocols

    PS Script to Enable Authentication

    The logic itself is handled by Calamari, which is open source. You are welcome to customize it by adding anything you need to it. The relevant code can be found here

    If you require any additional information or clarification please let me know :)

    Hope this helps!

    Kind Regards,

    Reece

  2. 2 Posted by pnolan on 15 Nov, 2017 06:18 AM

    pnolan's Avatar

    Thanks Reece.

    I think you may have provided the wrong link for the Step Template. It seems to be the link for the User Voice.

    --
    Kind Regards
    Patrick Nolan | Architecture Practice Lead
    e5 Workflow - Built for Business

    [image001]

    M. +61 (0) 435 172 112
    T . +61 (0) 2 9221 0070
    www.e5workflow.com<http://www.e5workflow.com/>

    • Please consider the environment before printing this email.
    P R I V I L E G E D AND C O N F I D E N T I A L
    This message is for the named person(s) use only. It may contain confidential, proprietary or legally privileged information of e5 Workflow Pty Ltd. No confidentiality or privilege is waived or lost by any mistransmission. If the reader of this message is not the intended recipient, or the employee responsible for delivering the message to the intended recipient(s), please notify us immediately by telephone at the number noted above. Any distribution or copying of this communication is strictly prohibited

  3. Support Staff 3 Posted by Reece Walsh on 15 Nov, 2017 11:11 PM

    Reece Walsh's Avatar

    Hi Patrick,

    Thank you for getting back to me regarding this,

    I'm very sorry for the mistake there, you can find the previously referenced Step Template here.

    If you require any further assistance or clarification please let me know :)

    Again, thank you for your patience regarding this matter.

    Kind Regards,

    Reece

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac