External ids in okta not working.

Brent's Avatar

Brent

12 Sep, 2017 04:06 AM

I am still trying to test the external ids for the okta authentication provider. Currently I do not think it works with the default guide / settings. Has anyone gotten it to work so that groups can be setup within okta and then used in octopus deploy to configure the users settings

Thanks!

  1. 1 Posted by Brent on 13 Sep, 2017 02:33 PM

    Brent's Avatar

    So actually was able to solve this ourselves. We ended up having to do the following:

    Set the groups name to be roles and then set it to filter by regex with a .* pattern because of a bug in okta where it will not send roles if its none

    picture

  2. 2 Posted by Brent on 13 Sep, 2017 03:10 PM

    Brent's Avatar

    I am not sure if there is a way to set this to pick up the groups by default. I believe this setting was intended for that but it does not work as intended?

    https://github.com/OctopusDeploy/OpenIDConnectAuthenticationProvide...

  3. Support Staff 3 Posted by Daniel Fischer on 14 Sep, 2017 06:01 AM

    Daniel Fischer's Avatar

    Hi Brent,

    Thanks for the the information here! Your resolution is the same that we came to. We have just created a GitHub issue to look into this further and see if we can find any other issues here. Once we have some more information we are going to update our documentation.

    If you would like to keep an eye on the GitHub issue: https://github.com/OctopusDeploy/Issues/issues/3797

    Please feel free to let me know if you find any further information or have any questions. :)

    Best regards,
    Daniel

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac