Downloading Nuget package and keeping it in Octopus server

prabhatkumar.singh's Avatar

prabhatkumar.singh

11 Aug, 2017 01:11 AM

Hi,

I have a special scenario. We are recently moving our CMS to Azure App service. The deployment to the CMS can be done by making an http post request with the package location using PowerShell. In the IAAS architecture we used to run the script inside the deployment targets.

In App service architecture i have an ability to whitelist my octopus server to run this script for the deployment. For this to happen i need to download my (nugget feed package/octopus server built in package) to be downloaded and place inside a specific location in octopus server. All the step templates which i found are trying to transfer the package to deployment targets after downloading. Since i don’t have any deployment targets it’s an App service it’s not working. Please note that i can’t use Octopus App service deployment since i don’t have to do web deploy. Any inputs will be really helpful.

  1. 1 Posted by prabhatkumar.si... on 11 Aug, 2017 05:37 AM

    prabhatkumar.singh's Avatar

    Aah i found this blog
    https://octopus.com/docs/how-to/how-to-run-steps-on-the-octopus-server and understood i can install tentacle in my octopus server and let it behave as a deployment targets. Will try this out

  2. Support Staff 2 Posted by Alex Rolley on 14 Aug, 2017 02:09 AM

    Alex Rolley's Avatar

    Hi Prabhatkumar,

    Thanks for getting in touch! Glad that you found our documentation useful!

    I just wanted to check that this worked as you expected and to see if there was anything else that we could do to assist?

    Regards,

    Alex

  3. 3 Posted by prabhatkumar.si... on 14 Aug, 2017 02:34 AM

    prabhatkumar.singh's Avatar

    Hi Alex,
     Yes it worked :)

    Sent from my iPhone

    On 14-Aug-2017, at 7:39 AM, Alex Rolley <[email blocked]<mailto:[email blocked]>> wrote:

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac