Upgrading Octopus from 3.3.27 to 3.13.3 Tentacle question

jsphillips's Avatar


12 May, 2017 05:48 PM

Hi, we are working on an upgrade plan to get to the latest version of Octopus and then to get on track to do scheduled upgrades more frequently to not get behind. My question is this:

With Octopus server requiring 4.5.1 going forward it says in the documentation that the tentacles can retain their current minimum .Net version. I am wondering will those servers that the tentacles reside on also have to have an upgrade of .net to 4.5.1 if we update all tentacles to the latest patch version.

Scott P

  1. 1 Posted by jsphillips on 12 May, 2017 06:43 PM

    jsphillips's Avatar

    To add to this will the newest version of Octo.exe also require 4.5.1 .Net Framework to work properly ? If so I will need to make sure my Jenkins Server has that upgrade also.

  2. 2 Posted by Vanessa Love on 15 May, 2017 12:45 PM

    Vanessa Love's Avatar

    Hi Scott,

    Thanks for getting in touch! For the latest Tentacles you do need 4.5 https://octopus.com/docs/installation/installing-tentacles
    If you have servers that are stuck on less than 4.5 you need to install Tentacle 3.0.26 and then lock the Tentacles to that version or they will continually tell you they are out of date and require upgrading.

    We would recommend if your Tentacles can be upgraded to 4.5 that you do so and get the latest Tentacle as you can then use TLS 1.2 and also patch security updates from Windows.

    Please let me know if I can expand on any of this information.

  3. 3 Posted by jsphillips on 15 May, 2017 01:23 PM

    jsphillips's Avatar

    But if we lock the tentacles do we lose functionality? I’d be concerned about a deployment process having to be written two different ways because of different tentacle versions.

  4. 4 Posted by Vanessa Love on 16 May, 2017 01:07 PM

    Vanessa Love's Avatar

    Hi Scott,

    Calamari does the heavy lifting when it comes to deployments and processes. Tentacle does not. That was our intention with this model and why we can support older and newer server OSs.
    Octopus and Tentacle have not needed to have matching versions since 3.0.


  5. 5 Posted by jsphillips on 23 May, 2017 04:25 PM

    jsphillips's Avatar

    I ran a powershell script across all of our tentacles through a project which shows 4.5,4.5.1 and 4.6.1 installed on all of our machines so we should be good to go.

    Last question. I see that on some machines we have 2.0 installed along with 3.0 and 4.5. When a deployment occurs with a powershell script in place it appears to be using 2.0 to execute however once we upgrade to the latest version of Octopus will it automatically pick up that 4.5 is already installed and just swap to using that ?

  6. 6 Posted by jsphillips on 23 May, 2017 05:48 PM

    jsphillips's Avatar

    Let me re-phrase the above. I am seeing that the CLR Version is 2.0 however I am pulling back 4.5 .net framework. Is this fine or will we need to install the Windows Management Framework 4.0 on the servers to get powershell up to 4.0 ?

  7. 7 Posted by Vanessa Love on 24 May, 2017 08:37 AM

    Vanessa Love's Avatar

    Hi Scott,

    It is fine :) Calamari needs to work with specific (low) versions of both .NET and PowerShell as it is supported across multiple versions of Tentacle.
    The higher .NET version is mainly for security protocols on Tentacle and it will work.

    Please let me know how your upgrade goes and if you need any assistance.


  8. Paul Stovell closed this discussion on 01 Sep, 2017 10:03 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac