Web Config Transform Not Completed

kphelan's Avatar

kphelan

31 May, 2013 04:56 AM

I have a Web.config file as well as a Web.Development.config file, but when I deploy to Environment Development, the transform is not applied and my Web.config sections have not been updated as expected. Not sure what I am doing wrong.

  1. 1 Posted by Alex Cason on 31 May, 2013 08:31 AM

    Alex Cason's Avatar

    Hey kphelan,

    Have you set your Web.Development.config file Build Action as Content so that it's included in the package being used by Octopus?

  2. 2 Posted by kphelan on 31 May, 2013 12:32 PM

    kphelan's Avatar

    Yes, build action is set as content. In fact every environment config file ends up in the package and deployed, but the transform just doesn't happen.

  3. 3 Posted by bosko on 04 Jun, 2013 03:14 AM

    bosko's Avatar

    Hey kphelan, I was having the same issue as you. I had "XML transformation" check box checked on the step that was deploying my website but the transformations were not happening even though the transforms were in the package. After checking the "XML variables" check box as well, it started to perform the transformations. It doesn't seem like the correct solution but it got my web.config transforming

  4. 4 Posted by kphelan on 04 Jun, 2013 03:42 AM

    kphelan's Avatar

    Thanks bosko, I'll give it a shot. I ended up adding all the appsetting and connection string variables and checking that. It works for now, but I will need to add some other sections that will need to be replaced as well so I'll give your suggestion a shot and remove some of the variables I added and see if I can get it working.

  5. 5 Posted by kphelan on 04 Jun, 2013 05:50 AM

    kphelan's Avatar

    Well, that didn't seem to solve my issue. I removed one of the variables and tried to create and deploy a new release. When I checked the config file, it had not been updated other than the variables that were still there for the project. Any other ideas?

  6. 6 Posted by xavier.decoster on 19 Jun, 2013 12:31 PM

    xavier.decoster's Avatar

    Hitting a similar issue:
    - config transformations do happen (looking at the deployment logs)
    - publishing through FTP to WAWS, but all config files get deployed (in a non-transformed state)

  7. 7 Posted by Dave Hogan on 24 Jul, 2013 12:52 PM

    Dave Hogan's Avatar

    @bosko - that fixed it for me. Like you say though, it doesn't seem right that you have to enable it.

  8. 8 Posted by shearer3000 on 14 Sep, 2013 01:32 AM

    shearer3000's Avatar

    hi - any further info/fix regarding this issue? thanks

  9. 9 Posted by chris on 16 Oct, 2013 06:22 PM

    chris's Avatar

    @bosko - fixed it for me as well. Seems like a bug.

  10. Paul Stovell closed this discussion on 04 Jan, 2017 07:16 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac