Teamcity Octo.exe variabled

Andy Bloomfield's Avatar

Andy Bloomfield

19 Feb, 2018 04:21 PM

I am trying to create a release from teamcity with 2 variables.
The command currently running is:
octo.exe create-release --server http://octopusserver --apikey SECRET --project logging form release --enableservicemessages --version 1.0.111 -v Client:pvh -v BuildId:13692

However the variables in the octopus release have not been set, therefore failing the release. Both variables are set to prompt, and have no default value.

Any help would be appreciated.

  1. Support Staff 1 Posted by Kenneth Bates on 21 Feb, 2018 05:07 AM

    Kenneth Bates's Avatar

    Hi Andy,

    Thanks for getting in touch! I'm terribly sorry for the delay in getting back to you. Am I correct in assuming that you've bound either the Client or BuildId prompted variable to the package ID in your package step? If I'm correct in my assumption, this is actually the expected behavior you're experiencing. Providing a value to a prompted variable happens at deployment time instead of at release creation time, which is when the package details need to be supplied.

    If I'm incorrect at all, please let me know! Could you provide additional details, like any error messages you're seeing to help us understand what could be going on better?

    I look forward to hearing back!

    Kind regards,

    Kenny

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Octoppus.JPG 80.7 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac