Selected version 'null'

scott.mccollough's Avatar

scott.mccollough

13 Feb, 2018 09:31 PM

It looks like this might be a bug in 2018.2.x or in the latest release of the Octopus Deploy Integration for VSTS. This step worked fine last night and did not after we upgraded from 2018.1.4 to 2018.2.x. I tried rolling back to version 2018.1.5 but it broke my external feeds. It looks similar to the problem that was "fixed" in 2018.2.2?

I am using the VSTS build step Create Octopus Release:

  1. Support Staff 1 Posted by Matthew Caspers... on 14 Feb, 2018 03:01 AM

    Matthew Casperson's Avatar

    Hi Scott, thanks for reaching out.

    I'm sorry to hear that you have experienced this problem. It has been confirmed as a bug in Octopus 2018.2, and we have an issue open for it at https://github.com/OctopusDeploy/Issues/issues/4276.

    We have a developer working on this issue now, so I expect to see a fix for this published shortly. You can receive notifications from the GitHub issue to let you know when this has been resolved.

    Regards
    Matt C

  2. 2 Posted by scott.mccolloug... on 14 Feb, 2018 12:32 PM

    scott.mccollough's Avatar

    Thanks for the quick response. I see where the issue has been closed with a new release 2018.2.3 but it's not showing up on the downloads page yet.

  3. 3 Posted by scott.mccolloug... on 14 Feb, 2018 03:10 PM

    scott.mccollough's Avatar

    2018.2.3 has been installed and it looks like my builds are working again. Thank you.

  4. scott.mccollough closed this discussion on 14 Feb, 2018 03:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac