Automatic Package Selection Version Rules for Channels not working in 2018.2.1

Wesley Pattison's Avatar

Wesley Pattison

09 Feb, 2018 08:45 AM

I am having a issue with automatic package selection during creating a release from the Web UI that is causing my package to not be found. In the rule designer (See screenshot), you'll see that here Octopus is able to correctly determine the version to use by making 4.0.0-beta green while striking out the other. I have verified that the rule is hooked up to the correct step. Once I visit the create release page (See other screenshot), I see that the Copy Tenant Configuration step could not find any package matching the defined rules.

Here is some additional notes that I have made.
- It seems the rule looks at the first package in the repository and determine if this is a match or not. If it isn't, it doesn't bother to iterate through.
- I have tried to create a new channel with just a simple rule, but to no luck I get the same result. 1 unknown package version warning.
- I have tried to reupload the same package after deleting it from the repository but this doesn't fix anything.

  1. 1 Posted by Wesley Pattison on 09 Feb, 2018 08:53 AM

    Wesley Pattison's Avatar

    I would also like to add that I was surprised our nightly builds from TFS did not break due to not being able to find the correct version for the tenantconfiguration package. This leads me to believe the bug is in UI Octopus.

    Also, I took a look at the network traffic and saw the request to retrieve packages with the filter I have setup. In it was a take=1 which returned nothing. If I copied the cURL (bash) to postman and run this call but with take=2 I actually see only 1 package but it is the correct package be selected.

  2. 2 Posted by chris.jones on 09 Feb, 2018 10:05 AM

    chris.jones's Avatar

    I am having same problem this morning, since upgrade to 2018.2.1, failing to create release from build step.

    When I try manual create release, many packages do not have a selected version; some "Latest" packages are selected but none of the available "Last" packages are selected, even though they should match.

  3. Support Staff 3 Posted by Pawel Pabich on 12 Feb, 2018 06:11 AM

    Pawel Pabich's Avatar

    Hi,

    Thanks for getting in touch! Unfortunately this is a bug we've introduced in the release we shipped last week. I've created an issue so you can track the progress of our work. We are already working on a fix.

    Regards,

    Pawel

  4. 4 Posted by Wesley Pattison on 14 Feb, 2018 09:44 AM

    Wesley Pattison's Avatar

    Thanks Pawel! I can confirm this is working again in the latest update.

  5. Wesley Pattison closed this discussion on 14 Feb, 2018 09:44 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac