Error: The dependency service or group failed to start

Francisco Santos's Avatar

Francisco Santos

08 Feb, 2018 04:10 PM

Saving instance: Tentacle
Setting home directory to: C:\Octopus
A certificate already exists, no changes will be applied.
Removing all trusted Octopus servers...
These changes require a restart of the Tentacle.
Application directory set to: C:\Octopus\Applications
Services listen port: 10933
Tentacle will not listen on a port
These changes require a restart of the Tentacle.
Waiting for service to become Stopped. Current status: Stopped
Service stopped
Proxy username cleared
Proxy password cleared
Proxy use is disabled
Error: ===============================================================================
Error: Cannot start service OctopusDeploy Tentacle on computer '.'.
Error: System.InvalidOperationException
Error: at System.ServiceProcess.ServiceController.Start(String[] args)
Error: at Octopus.Shared.Startup.ConfigureServiceHelper.ConfigureService()
Error: at Octopus.Shared.Startup.AbstractCommand.Start(String[] commandLineArguments, ICommandRuntime commandRuntime, OptionSet commonOptions)
Error: at Octopus.Shared.Startup.ConsoleHost.Run(Action`1 start, Action shutdown)
Error: at Octopus.Shared.Startup.OctopusProgram.Run()
Error:
Error: --Inner Exception--
Error: The dependency service or group failed to start
Error: System.ComponentModel.Win32Exception
Error: -------------------------------------------------------------------------------
Error: Terminating process with exit code 100
Error: Full error details are available in the log files at:
Error: C:\Octopus\Logs
Error: C:\Users\DevUser\AppData\Local\Octopus\Logs
Error: If you need help, please send these log files to https://octopus.com/support
Error: -------------------------------------------------------------------------------
Error:
Error: The previous command returned a non-zero exit code of: 100
Error: The command that failed was: "C:\Octopus\Octopus Deploy\Tentacle\Tentacle.exe" service --instance "Tentacle" --start
Deleted instance: Tentacle

  1. Support Staff 1 Posted by Mark Rydstrom on 08 Feb, 2018 11:46 PM

    Mark Rydstrom's Avatar

    Hi,

    Can you tell me what you are doing when you get this log? Are you installing a Tentacle? Upgrading a Tentacle? If you are using a script to do this can you sent me the script?

    Regards,
    Mark

  2. 2 Posted by Francisco Santo... on 09 Feb, 2018 07:37 AM

    Francisco Santos's Avatar

    Hi,

    Hi Mark,

    Thanks for your help.

    First I installed Octopus.Tentacle.3.4.12-x64 ; then I removed it and I installed Octopus.Tentacle.3.17.0-x64; so I received that log.
    I changed the default installation folder in the wizard, the rest I clicked next.

    bye

    From: Mark Rydstrom [mailto:[email blocked]]
    Sent: viernes, 09 de febrero de 2018 0:47
    To: Francisco Santos <[email blocked]>
    Subject: Re: Error: The dependency service or group failed to start [Problems #69077]

    // Please reply above this line
    ==================================================

    From: Mark Rydstrom (Support staff)

    Hi,

    Can you tell me what you are doing when you get this log? Are you installing a Tentacle? Upgrading a Tentacle? If you are using a script to do this can you sent me the script?

    Regards,
    Mark

    On Thu, Feb 08 at 08:10 AM PST, francisco santos wrote:

    Saving instance: Tentacle
    Setting home directory to: C:\Octopus
    A certificate already exists, no changes will be applied.
    Removing all trusted Octopus servers...
    These changes require a restart of the Tentacle.
    Application directory set to: C:\Octopus\Applications
    Services listen port: 10933
    Tentacle will not listen on a port
    These changes require a restart of the Tentacle.
    Waiting for service to become Stopped. Current status: Stopped
    Service stopped
    Proxy username cleared
    Proxy password cleared
    Proxy use is disabled

  3. Support Staff 3 Posted by Mark Rydstrom on 09 Feb, 2018 07:59 AM

    Mark Rydstrom's Avatar

    Hi,

    It is giving an error when we try to start the OctopusDeploy Tentacle service. Can you:

    1. Check the service list on the machine and see if it has installed?
    2. If it is can you start it manually in the service list?
    3. If it fails can you check the Windows event log and see if that contains any information.

    If the service isn't installed if you try and install again does it give the same error?
    Do you have anti-virus software installed, if so can you disable that temporarily and see if that helps?

    Regards,
    Mark

  4. 4 Posted by Francisco Santo... on 09 Feb, 2018 08:04 AM

    Francisco Santos's Avatar

    Hi,
    My answer is inline

    From: Mark Rydstrom [mailto:[email blocked]]
    Sent: viernes, 09 de febrero de 2018 8:59
    To: Francisco Santos <[email blocked]>
    Subject: Re: Error: The dependency service or group failed to start [Problems #69077]

    // Please reply above this line
    ==================================================

    From: Mark Rydstrom (Support staff)

    Hi,

    It is giving an error when we try to start the OctopusDeploy Tentacle service. Can you:

      1. Check the service list on the machine and see if it has installed?
    Yes i have a Windows service but I don´t have any exe in the folder ; because I uninstalled it.

      1. If it is can you start it manually in the service list?
    I recieved the error show you

      1. If it fails can you check the Windows event log and see if that contains any information.
    I don´t see Any information in the event log

    If the service isn't installed if you try and install again does it give the same error?
    yes.

    Do you have anti-virus software installed, if so can you disable that temporarily and see if that helps?

    no

    Regards,
    Mark

    On Thu, Feb 08 at 11:37 PM PST, Francisco Santos wrote:

    Hi,

    Hi Mark,

    Thanks for your help.

    First I installed Octopus.Tentacle.3.4.12-x64 ; then I removed it and I installed Octopus.Tentacle.3.17.0-x64; so I received that log.
    I changed the default installation folder in the wizard, the rest I clicked next.

    bye

  5. Support Staff 5 Posted by Mark Rydstrom on 09 Feb, 2018 08:14 AM

    Mark Rydstrom's Avatar

    I think things might just be in a bit of an inconsistent state. Can you try deleting any tentacle instances with the "Delete this Tentacle instance" option in the Octopus Tentacle Manager application. Uninstall the Tentacle app in Add/Remove programs. Clear out the install folders, and manually remove any tentacle services, then try running the installer again?

    Mark

  6. 6 Posted by Francisco Santo... on 09 Feb, 2018 08:42 AM

    Francisco Santos's Avatar

    How can i manually remove any tentacle services?
    I used “installutill /u” but it has been removed from windows services

    From: Mark Rydstrom [mailto:[email blocked]]
    Sent: viernes, 09 de febrero de 2018 9:14
    To: Francisco Santos <[email blocked]>
    Subject: Re: Error: The dependency service or group failed to start [Problems #69077]

    // Please reply above this line
    ==================================================

    From: Mark Rydstrom (Support staff)

    I think things might just be in a bit of an inconsistent state. Can you try deleting any tentacle instances with the "Delete this Tentacle instance" option in the Octopus Tentacle Manager application. Uninstall the Tentacle app in Add/Remove programs. Clear out the install folders, and manually remove any tentacle services, then try running the installer again?

    Mark

    On Fri, Feb 09 at 12:04 AM PST, Francisco Santos wrote:

    Hi,
    My answer is inline

  7. Support Staff 7 Posted by Mark Rydstrom on 09 Feb, 2018 08:55 AM

    Mark Rydstrom's Avatar

    You should be able to remove them with sc delete. See https://superuser.com/questions/135532/remove-windows-service-from-... for example.

    Mark

  8. 8 Posted by Francisco Santo... on 09 Feb, 2018 11:41 AM

    Francisco Santos's Avatar

    Hi again,

    I did your steps but the service shows the same message.
    I removed everything and installed the tentacle.
    Then I used powershell to clean again and I get the same.

    The server is in Azure, Windows Server 2008 R2 SP1

    From: Mark Rydstrom [mailto:[email blocked]]
    Sent: viernes, 09 de febrero de 2018 9:56
    To: Francisco Santos <[email blocked]>
    Subject: Re: Error: The dependency service or group failed to start [Problems #69077]

    // Please reply above this line
    ==================================================

    From: Mark Rydstrom (Support staff)

    You should be able to remove them with sc delete. See https://superuser.com/questions/135532/remove-windows-service-from-...<https://superuser.com/questions/135532/remove-windows-service-from-command-line> for example.

    Mark

    On Fri, Feb 09 at 12:42 AM PST, Francisco Santos wrote:

    How can i manually remove any tentacle services?
    I used “installutill /u” but it has been removed from windows services

  9. Support Staff 9 Posted by Mark Rydstrom on 11 Feb, 2018 11:59 PM

    Mark Rydstrom's Avatar

    I just tried in a new Azure Win 2008 vm and things worked okay for me. Are you still changing the installation directory? If so where are you trying to install it? Can you give it a try with just the default installation path?

    Mark

  10. 10 Posted by Francisco Santo... on 14 Feb, 2018 02:06 PM

    Francisco Santos's Avatar

    Hi,

    Finally i had to reinstall windows server in the machine and then everything was ok
    thanks

    From: Mark Rydstrom [mailto:[email blocked]]
    Sent: lunes, 12 de febrero de 2018 1:00
    To: Francisco Santos <[email blocked]>
    Subject: Re: Error: The dependency service or group failed to start [Problems #69077]

    // Please reply above this line
    ==================================================

    From: Mark Rydstrom (Support staff)

    I just tried in a new Azure Win 2008 vm and things worked okay for me. Are you still changing the installation directory? If so where are you trying to install it? Can you give it a try with just the default installation path?

    Mark

    On Fri, Feb 09 at 03:41 AM PST, Francisco Santos wrote:

    Hi again,

    I did your steps but the service shows the same message.
    I removed everything and installed the tentacle.
    Then I used powershell to clean again and I get the same.

    The server is in Azure, Windows Server 2008 R2 SP1

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • OctopusTentacle.txt 6.78 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac