Not able to disable a step

Amit Jaura's Avatar

Amit Jaura

23 Jan, 2018 02:26 PM

Getting error on disabling a step in the Process

There was a problem with your request.
'XXXXXX' could not be disabled because it is used as part of the release creation strategy.

I've started facing this issue after update to 4.0

  1. 1 Posted by Amit Jaura on 23 Jan, 2018 02:30 PM

    Amit Jaura's Avatar

    This is what it displays.

  2. Support Staff 2 Posted by Kenneth Bates on 24 Jan, 2018 06:00 AM

    Kenneth Bates's Avatar

    Hi Amit,

    Thanks for getting in touch! I'm sorry to hear you're hitting this issue when trying to disable your step. Recently we've fixed an issue to prevent disabling a step when this step is used by Automatic Release Creation. Your screenshots show that ARC isn't configured, so this is a bit curious.

    Are you able to successfully disable other steps in the same project?
    If so, could you check via the API if this project has ARC somehow incorrectly defined? You can reference the project ID at OctoURL/api/projects, and view this specific project at OctoURL/api/projects/projects-ID, where the ReleaseCreationStrategy would be populated.

    If that's defined, you can run the script at the following URL to disable ARC from this project, and that should fix it.
    https://github.com/OctopusDeploy/OctopusDeploy-Api/blob/master/REST...

    I hope this helps! I look forward to hearing back and getting to the bottom of this. :)

    Best regards,

    Kenny

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Capture.PNG 47.4 KB
  • Capture.PNG 47.4 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac