Project: 'All Variables' Tenant variables that use a default value do not display

Bob Ahlrichs's Avatar

Bob Ahlrichs

05 Jan, 2018 08:38 PM

Octopus v4.1.1

For a Project add a new Project Template Varialble. Control Type= 'Multi-line text box' with a default value
Connect this project to a Template
View the Tenants Variables and the Default Value displays as a watermark (expected)
When viewing a Project's "All Variables" view, it's great that we can see Tenant variable values! However, there are many instances where a Tenant is relying on the default value of a variable template. While these default values appear on the Tenant's variable entry screen as watermarks, they don't show up on the "All Variables" screen at all but are blank and noted as "Missing a value". This screen has been very valuable to us in making variable change decisions to know who's using what variable values. Without the default values showing we don't know if the value is the default or if it's actually blank without searching elsewhere.

  1. Support Staff 1 Posted by Kenneth Bates on 08 Jan, 2018 06:05 AM

    Kenneth Bates's Avatar

    Hi Bob,

    Thanks for getting in touch. I'm just letting you know here that I've reproduced this issue, which is included in the aforementioned issue that you can track here.
    https://github.com/OctopusDeploy/Issues/issues/4149

    Best regards,

    Kenny

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac