Automated Deploy when there shouldn't be one

aworrell's Avatar

aworrell

15 Nov, 2017 06:10 PM

I recently set up a new project with the "Deploy a package" step. I have not assigned any triggers to the project. In my build solution, I am using octo.exe to push a package to the internal nugget feed and create a release. As soon as the release is created it is deployed to an environment. In the past, when using the deploy a nuget pacakge step, this never occured. Where do I look to turn that off for my project and allow the deploy-release function in octo.exe control what I want deployed and when.

  1. Support Staff 1 Posted by Reece Walsh on 16 Nov, 2017 05:27 AM

    Reece Walsh's Avatar

    Hi Allen,

    Thank you for contacting Octopus Deploy support in regards to this query,

    Based on the information provided in your query, it sounds like, within your specified Lifecycle, Octopus is configured to automatically deploy to the environment upon release creation.

    To resolve this issue without making changes to your command line process you can simply update the lifecycle and change the environment from "Automatically Deploy" to "Manually Deploy".

    For further information on this please refer to the following documentation on Lifecycle Phases

    If you have any additional queries or require clarification please let me know :)

    Kind Regards,

    Reece

  2. 2 Posted by aworrell on 17 Nov, 2017 06:10 PM

    aworrell's Avatar

    That seems to be it Reece. I didn't realize the lifecycle was set up that way. I removed it as an option and have the results that I expected.

  3. Support Staff 3 Posted by Reece Walsh on 20 Nov, 2017 07:10 AM

    Reece Walsh's Avatar

    Hi Allen,

    Thank you for getting back to me regarding this, I greatly appreciate you letting me know the outcome.

    I'm glad that you have the solution in-hand.

    If you require any further assistance or clarification in the future please let me know :)

    Kind Regards,

    Reece

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac