Octo CLI Tool project creation problem

Marvin's Avatar

Marvin

12 Oct, 2017 07:38 AM

Hi,

I'm trying to create a project with the Octopus CLI Tool (latest version), but it keeps telling me:

"Finding project group: XYZ
Project group does not exist, it will be created
There was a problem with your request.

 - A project group with this name already exists. Please choose a different name."

This is pretty weird. It may work the first time I call octo.exe, but then when adding another project to the same group, the command will fail again. All rights have ben set for the API Key for creating, viewing, modifying projects and groups.

Octo.exe create-project --name ${projectName} --server http://localhost:8081/ --apiKey $OctopusApiKey --projectGroup ${project_group} --lifecycle \"Default Lifecycle\" --ignoreIfExists

Thanks!

  1. Support Staff 1 Posted by Dalmiro Grañas on 12 Oct, 2017 05:41 PM

    Dalmiro Grañas's Avatar

    Hi,

    Thanks for reaching out.

    Could you add the switch --debug to your command, then run it again and send me a screenshot of the full output of it? I want to see the full output as it will show the version of the Octopus server you are using, along with the CLI tool version.

    Thanks,
    Dalmiro

  2. Paul Stovell closed this discussion on 24 Jan, 2018 04:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac