Deployment of untenanted project does not display correct eligible targets

James's Avatar

James

17 Jul, 2017 02:00 PM

I have a project which is currently set to Allow deployments with or without a tenant, and has a single tenant attached to it. I've switched one of our deployment targets to Include in both tenanted and un-tenanted deployments, and has a tenant tag set that also matches the tenant attached to the project.

When I try to deploy a release for the project to Tenants, everything seems to work correctly (screenshot 1). However, if I switch to deploy to Environments, the target is picked up but is crossed off as if it's not eligible (screenshot 2).

When I go to deploy, everything works as expected, it's just odd that the targets show as not eligible.

  1. Support Staff 1 Posted by Michael Noonan on 18 Jul, 2017 10:48 AM

    Michael Noonan's Avatar

    Hi James,

    Thanks for getting in touch! I'm really sorry about this. I think you've run into this bug:

    https://github.com/OctopusDeploy/Issues/issues/3178

    We have had some problems with this preview for a little while, but it's become a real problem as we've introduced recent features. This bug is now our highest priority to fix.

    If it gives you any comfort, this is only a display/preview bug - the deployment will work as you'd expect.

    Hope that helps!
    Mike

  2. Paul Stovell closed this discussion on 01 Nov, 2017 04:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac