Problems executing NUnit tests

vane.27.04's Avatar

vane.27.04

20 Apr, 2017 08:44 PM

I'm trying to execute a set of Selenium tests with NUnit via Octopus. I've already imported the step template for NUnit and configured the parameters for it.
There are two problems now:

1. I get this output when executing the tests with octopus but not when executing them in the test machine:
1492718257220 addons.manager DEBUG Application has been upgraded
April 20th 2017 15:57:41
Info
1492718257466 addons.manager DEBUG Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider"]
April 20th 2017 15:57:41
Info
1492718257470 addons.manager DEBUG Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]

There's a lot of these lines, like 100. I read that this problem is between Selenium and Firefox but I don't understand why I get this output with octopus but not when running it in the machine.

2. I need to execute the tentacle service with an specific user. When I configure the "Log on" tab for the service with the user I need the tests don't run (I checked the service log and it says it's running with the user I need). Sometimes the execution freezes or sometimes it fails. However, when I manually execute the Tentacle.exe logged in the machine with the user I need the tests run successfully.

One thing I noticed it that when the tests fails this message is printed (In addition to the stack of prints from the first problem):
rash Annotation GraphicsCriticalError: |[0][GFX1-]: [D3D11] create swap chain failed: 0x887a0022, 0 (t=94.2128)|[1][GFX1-]: [D3D11] create swap chain failed: 0x887a0022, 0 (t=107.803)[GFX1-]: [D3D11] create swap chain failed: 0x887a0022, 0

So yeah, I'm lost as of what could be the problem.
Thanks in advance.

  1. Support Staff 1 Posted by Robert Wagner on 21 Apr, 2017 01:23 AM

    Robert Wagner's Avatar

    Hi Vane,

    Thanks for getting in touch. It sounds like the problem is due to the process running the selenium tests (Tentacle) cannot interact with the browser to run the tests as it is running as a Windows service. You may have some luck by enabling the interact with desktop option.

    Robert W

  2. 2 Posted by vane.27.04 on 21 Apr, 2017 07:59 PM

    vane.27.04's Avatar

    Thanks for the fast reply.
    I was really hoping this would fix our problems but it didn't seem to work.
    For the moment we'll stick with the workaround of executing the service manually and in the future search more about this.

  3. Paul Stovell closed this discussion on 27 Jul, 2017 09:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac