Cannot connect to Community Library

Luca Ghersi's Avatar

Luca Ghersi

07 Apr, 2017 01:03 PM

Hi, I can't connect to the community library, while the network is perfectly functioning.
My env is a newly installed Octopus 3.12.1.
This is the error:

The Octopus server failed to connect to our community library. http://g.octopushq.com/CommunityContributedStepTemplatesTroubleshooting
An error occurred while sending the request.
System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 40.112.143.214:443
   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)

The funny thing is that this IP address is actually an empty Azure web site.
Any idea? Do I need to configure something specific?

  1. Support Staff 1 Posted by Pawel Pabich on 10 Apr, 2017 01:44 AM

    Pawel Pabich's Avatar

    Hi Luca,

    Thanks for getting in touch! I just checked Community Library (https://library.octopus.com) stats and we've had 19 errors and 59000 successful requests in the last week. We also haven't heard anything about connectivity problems from other customers.

    Are there any firewalls or proxies between Octopus and the Internet?

    Regards,

    Pawel

  2. 2 Posted by Martin Gardiner on 12 Apr, 2017 10:15 AM

    Martin Gardiner's Avatar

    Hello,

    I'm having the same problem. We have a forward proxy that requires credentials & these have been entered. If I browse the library via Library | Step Templates & then click the 'community library website' link then I get to the library with no pop-ups requesting credentials.

    If I execute the Configuration | Features | Sync Now task then I get the same error as the OP, although for me I get re-directed to https://octopus.com/docs/administration/octopus-community-step-templates-integration rather than being in an empty Azure site.

    Regards,

    Martin.

  3. Support Staff 3 Posted by Pawel Pabich on 13 Apr, 2017 01:39 AM

    Pawel Pabich's Avatar

    Hi Martin,

    Thanks for getting in touch! You get redirected because the link in the error message is a shortlink.

    Library integration uses the same proxy as the one that is configured in Octopus Server so technically speaking it should assuming the proxy allows calls to the internet. Can you check that for me?

    Also, can you send me a screenshot of your Web Proxy Settings in Octopus?

    Regards,

    Pawel

  4. 4 Posted by Martin.GARDINER on 13 Apr, 2017 07:20 AM

    Martin.GARDINER's Avatar

    Hello Pawel,

    Thanks for the reply – I have got the library sync working now. I had the proxy set to use the IE proxy with custom credentials and, for whatever reason, this doesn't work for me. But changing it to custom & actually entering the proxy details solves the problem.

    Regards,

    Martin.

  5. 5 Posted by Luca Ghersi on 13 Apr, 2017 07:21 AM

    Luca Ghersi's Avatar

    Hi, same here! I had to manually enter my proxy configuration in Octopus to make it work. Use IE proxy option doesn't work.

  6. Support Staff 6 Posted by Pawel Pabich on 18 Apr, 2017 12:03 AM

    Pawel Pabich's Avatar

    Hi,

    I'm glad that both you managed to get the synchronisation working.

    The only reason I can think of re why it did not work out of the box is that the user (possibly you) who runs IE is already authenticated against the proxy whereas the user used by the Octopus server is not.

    The simplest test would be to temporarily use your user to run Octopus server and see whether the sync works out of the box.

    Regards,

    Pawel

  7. 7 Posted by Martin.GARDINER on 18 Apr, 2017 02:00 PM

    Martin.GARDINER's Avatar

    Hello Pawel,

    Although it's working I think that there is a bug in there somewhere. There are four options on the web proxy page in the Octopus Manager, and the last two are relevant for me:

    · Use the proxy server configured in Internet Explorer, with custom credentials

    · Use a custom proxy server

    I've tested both using the same credentials – the IE proxy with custom credentials fails, and explicitly entering the proxy IP & port succeeds.

    One final piece of information – our network admins have locked down the IE settings from the desktop, they are set by GPO. The IE proxy settings call a pac script rather than define an IP.

    Regards,

    Martin.

  8. Support Staff 8 Posted by Pawel Pabich on 18 Apr, 2017 11:33 PM

    Pawel Pabich's Avatar

    Hi Martin,

    Thanks for the details. I tested Octopus with proxy settings specified in a PAC file and it worked just fine. What is the account you are using to run Octopus Server? Are you in a position to perform the test I mentioned before?

    Regards,

    Pawel

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

25 Apr, 2017 04:28 PM
25 Apr, 2017 04:08 PM
25 Apr, 2017 04:04 PM
25 Apr, 2017 03:43 PM
25 Apr, 2017 03:39 PM

 

25 Apr, 2017 03:31 PM
25 Apr, 2017 03:28 PM
25 Apr, 2017 03:11 PM
25 Apr, 2017 02:54 PM
25 Apr, 2017 02:27 PM
25 Apr, 2017 01:17 PM