Unable to parse sensitive-variables as valid JSON.

john.bowker's Avatar

john.bowker

23 Mar, 2017 11:41 PM

Hi,

We upgraded to Octopus 3.11.13 yesterday and have found an issue with our SSH deploy projects. When deploying a package it fails with 'Unable to parse sensitive-variables as valid JSON.'.

We've tried upgrading to 3.11.14 as well as turning off json config substitution however nothing has worked.

Nothing has changed in your project steps or variables.

  1. Support Staff 1 Posted by Shane Gill on 24 Mar, 2017 03:52 AM

    Shane Gill's Avatar

    Hi John,

    Sorry about that. A fix will be out shortly: https://github.com/OctopusDeploy/Issues/issues/3335

    Downgrading to 3.11.11 in the meantime should fix the issue.

    Cheers
    Shane

  2. 2 Posted by john.bowker on 24 Mar, 2017 08:59 AM

    john.bowker's Avatar

    Thanks for the update Shane.

  3. 3 Posted by john.bowker on 27 Mar, 2017 01:56 AM

    john.bowker's Avatar

    Any ETA on this being released?

  4. Support Staff 4 Posted by Shane Gill on 27 Mar, 2017 05:13 AM

    Shane Gill's Avatar

    Hi John,

    We just released 3.11.15 which contains the fix for this issue. Thanks for the patience.

    Cheers,
    Shane

  5. 5 Posted by john.bowker on 30 Mar, 2017 08:51 AM

    john.bowker's Avatar

    Had this version running for the past few days and works great.

    Thanks Shane

  6. 6 Posted by ebenkrapfl on 14 Apr, 2017 02:03 AM

    ebenkrapfl's Avatar

    I am actually running across the same issue when using an offline package drop with sensitive variables. I am getting the "unable to parse sensitive-variables as valid json" message, and I am never being prompted for a password. Running Octopus 3.12.4, and it looks like Calamari version 3.7.51 from the offline package drop.

    Thanks,
    Eben

  7. 7 Posted by ebenkrapfl on 17 Apr, 2017 05:37 PM

    ebenkrapfl's Avatar

    I think I figured out the problem I was running across. It wouldn't let me deploy the offline packages (from octopus) without putting a password on the deployment target (saying that I had sensitive variables... but I didn't). Putting a password on the deployment target should have prompted me for that password when we ran the commands on the machine (but it didn't). What I figured out is that even though I didn't have sensitive variables, there is one sensitive field in the process that I was using a non-sensitive variable to populate. I think that confused the process somehow.

    TLDR;
    I marked the variables that go into the process as sensitive parameters as sensitive, so now it actually prompts me for a password, and all is well.

    Thanks,
    Eben

  8. Support Staff 8 Posted by Shane Gill on 19 Apr, 2017 04:05 AM

    Shane Gill's Avatar

    Hi Eben,

    Thanks for letting us know how you resolved the problem. I'll see what we can do to ensure it doesn't happen again.

    Cheers,
    Shane

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

25 Apr, 2017 04:08 PM
25 Apr, 2017 04:04 PM
25 Apr, 2017 03:43 PM
25 Apr, 2017 03:39 PM
25 Apr, 2017 03:31 PM

 

25 Apr, 2017 03:28 PM
25 Apr, 2017 03:11 PM
25 Apr, 2017 02:54 PM
25 Apr, 2017 02:27 PM
25 Apr, 2017 01:17 PM
25 Apr, 2017 11:14 AM